İsmailAltınok.com Genel,Sistem CISCO Router ve Switch Temel Yapılandırma Komutları

CISCO Router ve Switch Temel Yapılandırma Komutları



Merhaba,

Bu yazımda giriş seviyesinde CISCO Ağ cihazları üzerinde temel yapılandırma komutlarından bahsedeceğim.

İlk olarak CISCO cihazlardaki modlardan bahsetmek istiyorum. Temel olarak 3 mod vardır. Hangi modda olduğunuzu cihaz isminden sonraki karakterden anlayabilirsiniz. >,#,(config)# şeklinde.

Router>  Kullanıcı Modu. Kullanıcı modundan ayrıcalıklı moda geçmek için enable komutunu kullanırız.

Router# Ayrıcalıklı Mod. Ayrıcalıklı moda geçiş için configure terminal komutunu kullanırız.  Kullanıcı moduna geri dönmek için exit komutunu kullanırız.

Router(config)# Yapılandırma Modu. Ayrıcalıklı moda geri dönmek için exit komutunu kullanırız.

Cihaz adını Ankara olarak değiştirir.

Router(config)# hostname Ankara

Ayrıcalıklı mod(exec/enable) mod şifresini ayarlar.

Router(config)#enable password admin

Ayrıcalıklı mod(exec/enable) mod şifresini şifrelenmiş olarak atar. Bir önceki komutta password ile belirlediğimiz taktirde yapılandırma dosyasını okunarak şifremiz gözükebilir (show running-config) Buna engel olmak için secret ile şifre belirlememiz güvenlik açısından daha uygun olacaktır.

Router(config)#enable secret admin

Cihaz üzerinde belirlediğimiz şifreler encrypt edilerek okunamaz hale getirecektir. Güvenlik sebebiyle önemli bir komuttur.

Router(config)#service password-encryption

Bu kod ile ‘    ‘ karakterleri arasında belirleyeceğimiz IOS’a bağlanıldığında uyarı mesajı göstermek için kullanılır. ‘ ‘ karakterleri yerine başlangıç ve bitiş aynı olacak herhangi bir karakter kullanılabilir (#, ! vs.)

Router(config)#banner motd 'UYARI MESAJI'

 

Konsol kablosu ile bağlantıya şifre atamak için aşağıdaki kod grubu kullanıyoruz.

Router(config)#line console 0

Router(config-line)#password Ankara06

Router(config-line)#exec-timeout 1 30            //Herhangi bir işlem yapılmadığında 1 dakika 30 saniye sonra oturum kapanacak ve tekrar şifre soracaktır.

Router(config-line)#login                 //Belirlediğimiz şifreyi aktifleştirir.

Router(config-line)#exit

VTY Hatlarına (telnet) ile bağlantıya şifre atamak için aşağıdaki kod grubu kullanıyoruz.

Router(config)#line vty 0 15

Router(config-line)#password Ankara06

Router(config-line)#exec-timeout 1 30            //Herhangi bir işlem yapılmadığında 1 dakika 30 saniye sonra oturum kapanacak ve tekrar şifre soracaktır.

Router(config-line)#login                 //Belirlediğimiz şifreyi aktifleştirir.

Router(config-line)#exit

Cihaz üzerinde belirlenecek tüm şifrelerin minimum karakter sayısını belirtmek için aşağıdaki komutu kullanıyoruz.

Router(config)#security passwords min-lenght 6

Güvenlik için çok önemli bir diğer komut login block-for komutudur. Bu komut ile 2 dakika(120sn) içinde 5 hatalı giriş denemesi yapıldığında sistem kendisi  5 dakika(300sn) bekleme moduna almaktadır. Parametlerin saniye şeklinde yazılması gerekmektedir.

Router(config)#login block-for 300 attempts 5 within 120

 

SSH Yapılandırması

Router(config)#ip domain name ismailaltinok.com

Router(config)#username admin privilege 15 secret cisco  //Kullanıcı admin şifre cisco olarak belirliyoruz.(password ile şifre tanımlarsak config dosyasında şifrelenmemiş olarak tanımlarız.Enable ile şifre tanımlarsak config dosyasından şifremiz okunamayacak şekilde tanımlarız.)  Privilege 15 parametresi yetki seviyesi tanımlamak için kullanılmaktadır. İsterseniz yazmayabilirsiniz.

Router(config)#crypto key generate rsa generals-keys modulus 1024    //  1024 bitlik bir güvenlik anahtarı oluşturuyoruz.

Router(config)#ip ssh version 2   //Güvenlik sebebiyle ssh versiyonumuzu 2’ye yükseltiyoruz.

Router(config)#line vty 0

Router(config-line)#login local

Router(config-line)#transport input ssh      //Güvenli olmadığı için telneti devre dışı bırakıyoruz.

Router(config-line)#exit

DNS Aramasını devre dışı bırakmak için aşağıdaki komutu kullanıyoruz.

Router(config)#no ip domain-lookup

Router Ağ Arayüz IP Yapılandırmaları:

Router yapılandırmasından önce IP ile ilgili gerekli örnek tabloya bakabilirsiniz. Alt ağlara böldükten sonraki gerekli bilgiler tabloda mevcuttur.

Network(Ağ) Adresi Broadcast (Genel Yayın) Adresi Subnet Mask(Alt Ağ Maskesi) IP Bloğu (Toplam IP Sayısı) Kullanılabilir IP Adresi Ağ Geçidi(Default Gateway) Adresi Switch Adresi PC Adresi
192.168.1.0/24 192.168.1.255 255.255.255.0 256 254 192.168.1.1 192.168.1.2 192.168.1.3
192.168.1.0/25 192.168.1.127 255.255.255.128 128 126 192.168.1.1 192.168.1.2 192.168.1.3
192.168.1.128/26 192.168.1.191 255.255.255.192 64 62 192.168.1.129 192.168.1.130 192.168.1.131
192.168.1.192/27 192.168.1.223 255.255.255.224 32 30 192.168.1.193 192.168.1.194 192.168.1.195
192.168.1.224/28 192.168.1.239 255.255.255.240 16 14 192.168.1.225 192.168.1.226 192.168.1.227
192.168.1.240/29 192.168.1.247 255.255.255.248 8 6 192.168.1.241 192.168.1.242 192.168.1.243
192.168.1.248/30 192.168.1.251 255.255.255.252 4 2 192.168.1.249 192.168.1.250            –

Router(config)#interface gigabitEthernet0/0  //Hangi portu yapılandırmak istiyorsak giriş yapıyoruz.

Router(config-line)#ip address 192.168.1.1 255.255.255.0   //Ağ geçidi(Default gateway) ve alt ağ maskesini(Subnet Mask) yazıyoruz.

Router(config-line)#no shutdown     //Ayarları aktif hale getiriyoruz.

Router(config-line)#exit

Router OSPF Yönendirme Yapılandırması

Router(config)#router ospf 1    //Ospf numarası(Process Numarası) tanımlıyoruz.

Router(config-router)#router-id 1.1.1.1  //Router için ID tanımlıyoruz.IP Numarasına benzer şekilde giriyoruz.Bu genelde 1.1.1.1, 2.2.2.2, 3.3.3.3 şeklinde olur.)

Router(config-line)#network 192.168.1.0 0.0.0.255 area 0

Router(config-line)#network 192.168.2.0 0.0.0.255 area 0 //Sırasıyla arasında yönlendirme yapacağımız networkleri tanımlıyoruz. Burada önemli olan Default gateway değil Ağ Adresini giriyoruz. Diğer önemli husus ise Subnet Mask değil Wilcard Mask giriyoruz.(Wilcard Mask basit şekilde Subnet Mask’ın tam tersi olarak düşünebiliriz.) Wilcard masktan sonra ise Area tanımlıyoruz. Arealar 0’dan başlar.

 

Switch IP Ve VLAN Yapılandırmaları:

Switchlerde ayrı ayrı VLAN’lar oluşturmayacaksak IP Yapılandırmaları gigabitEthernet0/0 gibi arayüzlerden değil VLAN arayüzü üzerinden yapılır.

Switch(config)#interface vlan 1     //Cisco switchler Varsayılan olan Vlan 1 kullanılmaktadır.

Switch(config-if)#ip address 192.168.1.2 255.255.255.0   //Switchimize IP tanımlıyoruz.

Switch(config-if)#no shutdown  //Yapılandırmayı aktif ediyoruz.

Switch(config-if)#exit  //Yapılandırma tamam çıkış yapıyoruz.

Switch(config)# ip default-gateway 192.168.1.1 // Default gateway(AĞ Geçidimizin) IP Adresini tanımlıyoruz.

 

VLAN Oluşturma

Switch(config)#vlan 10    //Yeni bir vlan oluşturup id tanımlıyoruz.

Switch(config-vlan)#name MERKEZ  //Oluşturduğumuz VLAN’a isim belirliyoruz.

Switch(config-vlan)#exit

Portları VLAN’a atamak;

Switch(config)#interface range fastethernet 0/1-5   //   Burada hangi portları/interface’leri vlan’a atama yapacağımızı belirliyoruz. 0/1-5 şeklinde yazarsak 1 ve 5 dahil arasındaki portları atamış oluruz. 0/1 şeklinde yazarsak sadece 0/1 numaralı portu atamış oluruz.

Switch(config-if-range)#switchport mode access   // Switch-PC ve Switch-Router arası yapılandırıyorsak Access, iki switch arasında yapılandırıyorsak Trunk olacaktır.

Switch(config-if-range)#switchport access vlan 10

Switch(config-if-range)#exit

Switchler Arası VLAN Oluşturma

Switch(config)#interface range fastethernet 0/10    //İnterface’imizi seçiyoruz.

Switch(config-if-range)#switchport mode trunk //Switchler arası VLAN’ın trunk modda olması gerekmektedir.

Switch(config-if)#switchport trunk native vlan 1

Switch(config-if)#switchport trunk allowed vlan 1,5,10,15  //Trunk portuna ( 0/10)  bağlayacağımız diğer vlanleri belirliyoruz.

Yardımcı Komutlar:

Cihazdaki port durumlarını gösterir.

Switch#show ip interface brief

Cihazdaki VLAN yapılandırmasını gösterir.

Switch#show vlan brief

Cihazdaki Routing yapılandırmasını gösterir.

Router#show ip route

Herhangi bir komutu iptal etmek için komutun başına no eklenir.

Switch#no enable password

Yapılandırma ayarlarını kaydetme

Switch#write    //Yapılandırma modunda do write şeklinde yazılır

Switch#clock set hh:mm:ss DD ay_adı yyyy  // hh: 24 formatında saat, dakika, saniye, gün,ingilizce olarak ay adı, yıl şeklinde girilir.

 

 

 

Bir Cevap Yazın

This site uses Akismet to reduce spam. Learn how your comment data is processed.